Installing and testing server

Discussion in 'Web Call Server 3' started by red8, Dec 16, 2014.

  1. red8

    red8 New Member

    We are installing WebRTC server. After installing, the traffic from PBX does go, while from the server - it does not. What could be the issue?
  2. Max

    Max Administrator Staff Member

    Try updating to the latest version
  3. red8

    red8 New Member

    Now WebRTC is working, but Flash has stopped working. I run Phone.html.
  4. Max

    Max Administrator Staff Member

    Phone.html is an example of a flash-based phone. A full-featured client with WebRTC and Flash you should use is PhoneJS.html.
  5. red8

    red8 New Member

    It works ok, while phoner js doesnt work in IE
    So we also consider a flash-based option
  6. Max

    Max Administrator Staff Member

    If the browser is not WebRTC-compatible, the client loads Flash automatically. Please try it in IE.
  7. red8

    red8 New Member

    Flash doesn't work correctly. Audio is missing, high latency. We are testing in the local network.
  8. Max

    Max Administrator Staff Member

    Can you say:
    1) do you test on different computers?
    2) version of the browser you see the problem
    3) version of Flash
  9. red8

    red8 New Member

    1) do you test on different computers?
    Yes different ones, the main one is i5 core

    2) version of the browser you see the problem
    Latest versions of IE, Opera

    3) version of Flash
    The latest from their website
  10. red8

    red8 New Member

    Strangely there is no audio in WebRTC now. I've sent logs to your email.
  11. Max

    Max Administrator Staff Member

    According to logs, the PBX sends strange re-INVITE requests directly after the call is established. So the audio stops. Requests conform to the specification, but look weird, its unclear why the PBX sends them. It will take some time to investigate those re-INVITEs.
    Last edited: Dec 21, 2014
  12. Max

    Max Administrator Staff Member

    The problem with re-INVITE is solved. Please update to the latest version.
  13. red8

    red8 New Member

    Now seems to work. Yet I don't get it, you fixed the re-Invite issue in WebRTC, but Flash also works ok now??
  14. Max

    Max Administrator Staff Member

    Probably, you have Chrome installed and the Flash Player updated in the background. May be that was the reason.

Share This Page