SIP as RTMP not working again

Discussion in 'Web Call Server 5' started by fromin, Apr 7, 2017.

  1. fromin

    fromin New Member

    Hi,

    so we tried to duplicate what we had working on our dev server to our live, but the call doesn't seem to be established correctly (after the first getStatus, it already returns "NO SUCH CALL" although the call should take over 100 seconds). I am sending an e-mail to logs@ now as well.

    Thanks
    Martin
  2. Max

    Max Administrator Staff Member

    Hello
    Your configuration looks correct.
    According your logs, your RTMP server does not receive RTMP stream.
    We have checked your RTMP server with FMLE. As you can see, connection was failed.
    Please check your RTMP endpoint and make sure it is working.

    rtmp.jpg
  3. fromin

    fromin New Member

    If it's the problem just with RTMP server not receiving the stream, why does the getStatus say "NO SUCH CALL" after 2 seconds of the call failing although the SIP call should take 100 seconds?
  4. Max

    Max Administrator Staff Member

    Because SIP call is linked with RTMP stream. If RTMP stream is failed, associated SIP call will be terminated immediately.
    If your SIP call is alive after RTMP fail, it looks like a bug because SIP call should be terminated.
    However in logs I see that call is terminated with BYE request.
  5. fromin

    fromin New Member

    Ok I fixed the RTMP and it works now. Only thing is that getStatus now returns the stream ID, but on the other server it returns "ESTABLISHED" - is that because I have a newer version on this server?
  6. Max

    Max Administrator Staff Member

    Yes it looks like be a bug with new version of server. We will check.
  7. fromin

    fromin New Member

    Ok so I made some adjustments, the RTMP looks like it's capturing it correctly, but I cannot hear any sound, although the call is exactly 1 minute 16 seconds which it should be. Please try - I set up a dummy call that repeats "One two three" for 76 seconds.
  8. Max

    Max Administrator Staff Member

    We have tested this with your server. It works fine.
    We tested on default samples:
    1. SIP as RTMP
    /demo2/sip-as-rtmp
    sip-rtmp.jpg
    2. Flash Streaming
    /demo2/flash-streaming
    flash.jpg

    As you can see, WCS adds prefix rtmp_ for stream name stream123. And you have to play stream rtmp_stream123.
    You can disable this prefix in flashphoner.properties.
  9. fromin

    fromin New Member

    Hmm, for some reason if I use the rtmp://dev.***.com as you did, it works, but with the other RTMP server (rtmp://staging.***.com), I'm not receiving the sound as I described earlier.
    I need this to work with staging
  10. fromin

    fromin New Member

    The RTMP server is Wowza and I just checked that the Wowza configuration is identical
  11. Max

    Max Administrator Staff Member

    WCS sends audio in AAC codecs in latest builds.
    Perhaps if you deploy the same Wowza version on your stage host, it would work properly.
    Other options:
    1. Switch to old engine in flashphoner.properties:
    Code:
    sip_as_rtmp_use_new_engine=false
    In such case WCS will use G.711 codec received from Twilio
    2. Use speex codec
    Code:
    force_rtmp_audio_codec=speex16
    You can try these two options in combination.
    These settings require WCS restart.
  12. fromin

    fromin New Member

    So I tried all of the combinations (restarted after modifying of course); results:

    sip_as_rtmp_use_new_engine=false
    ****
    streamnotfound when I tried to play the stream

    force_rtmp_audio_codec=speex16
    *****
    no sound (therefore no change when compared to the original settings)

    force_rtmp_audio_codec=speex16
    sip_as_rtmp_use_new_engine=false
    *****
    streamnotfound when I tried to play the stream
  13. fromin

    fromin New Member

    And yes I'm using the rtmp_ prefix when trying to play it (I'm trying it via the WCS dashboard)
  14. fromin

    fromin New Member

    Any news? I need to get this done ASAP
  15. Max

    Max Administrator Staff Member

    You can update to previous build
    2101
    And check if it works for you with:
    Code:
    sip_as_rtmp_use_new_engine=false
    or
    Code:
    sip_as_rtmp_use_new_engine=true
    The issue is under investigation. I will inform you if we have any news.
  16. Max

    Max Administrator Staff Member

    We have tested with latest build 2172 and our Twilio account.
    1. It works fine with default settings.
    2. It works with
    Code:
    sip_as_rtmp_use_new_engine=false
    Perhaps you have an issue with your Wowza configuration. Please test the build.

Share This Page