WCS3+Asterisk+EC2 No Audio issue

Discussion in 'Web Call Server 3' started by Indrajith K L, Sep 8, 2015.

  1. Indrajith K L

    Indrajith K L New Member

    We were using Flashphoner WCS3 + Asterisk + EC2 server for our application. But recently we are having an issue with audio. To check whether the issue is with WCS version we had upgraded to the latest version 3.0.1312. But still having the same issue. We had no issue since the last week though.

    Thanks.
    Last edited: Sep 8, 2015
  2. Max

    Max Administrator Staff Member

    First of all make sure UDP ports are open for this EC2 instance.
    Try to open all incoming and outbound UDP traffic.
    If still no audio, please send tcpdump to logs@flashphoner.com
    Code:
    tcpdump udp -s 2048 -i any -w log.pcap
    use flag '-i any' if asterisk is installed in one box with WCS.
    Send us:
    • pcap
    • server_logs/flashphoner.log
    • console output of chrome browser
    We will check.
    What is your operation system version? Browser version? Maybe browser was upgraded,
  3. Indrajith K L

    Indrajith K L New Member

    I had opened the all incoming and outbound UDP ports but no changes. :(

    OS is Ubuntu 14.04. I don't think so it will be the OS issue, I had tested it on Windows.
    I have attached the logs files you wanted.

    Thanks.

    Attached Files:

    Last edited: Sep 8, 2015
  4. Max

    Max Administrator Staff Member

    please attach log
    flashphoner.log.2015-09-08-11
    your flashphoner.log is almost empty
  5. Max

    Max Administrator Staff Member

    Try to set in flashphoner.properties:
    Code:
    ip=[amazon instance external IP]
    ip_local=[amazon instance local IP]
    Then restart WCS server.
  6. Indrajith K L

    Indrajith K L New Member

    Sorry, that was an uploading issue. Please see the attachements
    ip and ip_local are set to their amazon instance values.

    Attached Files:

  7. Max

    Max Administrator Staff Member

    Try to add to flashphoner.properties
    Code:
    enable_candidate_harvester=false
    and restart WCS server
  8. Indrajith K L

    Indrajith K L New Member

    Audio is working now (Thanks), but another issue came out. Audio session will cut off after 15 seconds. We tried adding "keep_alive.algorithm =INTERNAL" in server.properties (which solved the same problem in previous working setup) but calling keeps cuting off after 15 seconds. Also the sip client (We use Blink) shows a "media stream timeout" after 15 seconds before call cutoff. Any additional configuration to add on flashphoner.

    I have attached log files.. please see the attachments (zipped).

    Thanks.

    Attached Files:

    Last edited: Sep 9, 2015
  9. Max

    Max Administrator Staff Member

    Hello,
    Keep Alive settings are not applicable here. The keep alive settings are used for websocket and Flash connection only.
    As I see from logs and dumps, you have a normal call with two-way voice traffic between Asterisk and WCS.
    However Blink terminates the call session.
    So it seems as Blink issue.
    In the pcap log I see unanswered STUN requests from Blink to Asterisk server. Perhaps if you set another STUN server for Blink, it would work.
  10. Indrajith K L

    Indrajith K L New Member

    OK, I will check that.

    Thanks.
  11. Alain R. Mady

    Alain R. Mady New Member

    We have had the same issue and we resolved it easily... Reinstall the Flashphoner server... Good luck
  12. Mckenny87sj

    Mckenny87sj New Member

    It doesn't get fixed with me bro, can you please help me ?
  13. Max

    Max Administrator Staff Member

    Please create your own thread.

Share This Page