Audio stream over RTSP problem

Discussion in 'Web Call Server 5' started by Srdjan, Nov 24, 2019.

  1. Srdjan

    Srdjan New Member

    Hello Support,

    We are experiencing issues when trying to stream audio alongside video over RTSP protocol.
    This is happening only when using rtsp protocol.

    The facts :
    - When using RTMP to publish stream to our server we are not experiencing any issues but we have to use RTSP so this is not an option for us.
    -- When using AAC,AAC+ and AAC++ audio protocol we are getting video stream but we are not hearing any audio(Flashphoner log shows "audioCodec" : "opus" and "Stream Playing")
    --- When using 'G711A Over RTSP' we are not getting anything, not even video stream(Flashphoner logs shows "info" : "Can not get audio SDP","Stream failed" )
    ---- When using 'G711A Over RTSP' but with option 'Enable and Resample with 8k' we are getting Video and Audio as it should be(Flashphoner logs show "audioCodec":"PCMA" , sincerely with a lot noise but that is issue for other subject)
    ----- All this testing is made with option set on encoder itself "TS OVER RTSP=ES".When its set to "TS OVER RTSP=TS" we are always getting "No codecs found" and can't get anything.

    Our question is what audio protocol we can actually use when streaming audio and video over rtsp as resample with 8k is not giving us optimal quality ?If anything needs to be changed on server side please let us know what.

    If there are audio tweaks for suppressing noise etc please provide us with documentation regarding that if possible.

    I tried to provide as much details as possible.
    Please let me know if you need anything further.

    We will be awaiting your response.

    Regards,
    Srdjan I.
    Last edited: Nov 24, 2019
  2. Max

    Max Administrator Staff Member

    Good day.
    If you view these streams in VLC, do your have issues?
    Could you please share links to the streams for testing? If you can't share the stream, please provide:
    1. Pcap file:
    Code:
    tcpdump -s 4096 -w log.pcap
    2. Output of ffprobe command:
    Code:
    ffprobe -loglevel debug -i 'rtsp://<Your RTSP stream>'
    You have to install ffmpeg to get this probe.
    Please tell us which version of WCS you are using and send WCS logs:
    Code:
    cat /usr/local/FlashphonerWebCallServer/conf/WCS.version
    Code:
    /usr/local/FlashphonerWebCallServer/logs
    Last edited: Dec 2, 2019 at 10:20 AM
  3. Srdjan

    Srdjan New Member

    Hello Support,

    I've sent you the details over an e-mail.

    Let me know if you need anything else.

    Regards,
    Srdjan I.
  4. Max

    Max Administrator Staff Member

    Good day.
    We raised internal ticket (WCS-2388) and let you know results in this topic.
  5. Max

    Max Administrator Staff Member

    Good day.
    We've reproduced the issue and still work on it. You can use the following parameter in flashphoner.properties file as a temporary workaround:
    Code:
    use_fdk_aac=false

Share This Page