Memory Leak

Discussion in 'Web Call Server 5' started by Taylor, Aug 26, 2019.

  1. Taylor

    Taylor New Member

    Hi

    We have been using Flashphoner in a production environment for almost a week now and we are currently getting a few memory leak issues.

    We originally thought it was related to the JVM not having enough heap memory so we've increased it, as well as adding these other configurations:
    Code:
    -Xms6g -Xmx6g
    -XX:+UseConcMarkSweepGC -XX:NewSize=1024m
    
    However this didn't seem to fix it and the memory leak continues. The leak builds up and reaches it's maximum allocated space within about 2 days, by which time we have to restart the server.

    The "jmap.out.txt" shows the memory statistics from the JVM.
    The "uptime.out.txt" describes the running time for the instance.
    Both files were created at Aug 23 16:38 UTC
    The number of concurrent connections we get is less than 10, usually 3 to 5 on average.

    Any assistance on why this is occurring and how to fix it would be greatly appreciated.

    WCS version: 5.2.108 (3a8140311c1e80789857b139189acf4e74af6e2d)
    Flashphoner version: 0.5.28.2753.86 (218c188ea896656b1ca142f02b4f58bf09bd8bf1)
    AWS Instance Type: c5.xlarge

    Attached Files:

  2. Max

    Max Administrator Staff Member

    Good day.
    You are using relatively old build, there were many fixes made in latest builds concerning memory leaks. So please update to build 5.2.324 and check. If the problem persists, please collect a report as described here and send us to support@flashphoner.com, we will check.
  3. Taylor

    Taylor New Member

    Hi Max

    We are using an AWS image you provide to build our media server (https://aws.amazon.com/marketplace/pp/B01D1L5EAK) and currently the latest build on the marketplace is 5.2.267.

    We would like to deploy build 5.2.324 using an image from the marketplace rather than downloading and building it ourselves as it would be usable with our current start-up scripts as well as making it easy to re-build on our other servers if need be.

    When would the latest build be available from the marketplace?

    Cheers,
    Taylor
  4. Max

    Max Administrator Staff Member

    You can update to 5.2.267 if you don't use HLS in production.
    If issue still persists, please let us know.

Share This Page