Trouble connecting SIP to RTMP with Twilio, Wowza and Flashphoner

Discussion in 'Web Call Server 5' started by Sam Udotong, May 15, 2017.

  1. Sam Udotong

    Sam Udotong New Member

    I'm having trouble connecting to SIP through WCS 5 -- even in the :9091/dashboard.xhtml?demo2=demo2/sip-as-rtmp demo page, I get this message
    Code:
    AOOsuUF-zcH3Fp3-eKTbtGW-Q8xGNeb >>> rtmp://host:1935/live
    FINISHED
    but when connecting through the RTMP player, I get StreamNotFound.

    I've followed these guides/posts closely and have not been able to get a fix:

    https://www.codeproject.com/Articles/1058144/Taking-audio-stream-from-Twilio-by-SIP-and-sending
    https://flashphoner.com/docs/wcs5/w...-guide/index.html?sip_as_rtmp_with_twilio.htm
    http://forum.flashphoner.com/threads/sip-as-rtmp-streamnotfound-error.10805/

    I seem to be getting getting an INTERNAL_SIP_ERROR when executing the JSON POST request to the WCS server to start the audio stream. I've confirmed that I am able to get the SIP audio stream if I call into my twilio number with a real cellphone, and also through a softphone (Zoiper). However when I use the correct parameters in JSON POST request and then try to connect, it leaves me with StreamNotFound.

    I've sent my conf and logs over to the logs@ email address- any times?
  2. Max

    Max Administrator Staff Member

    Hello
    From your logs we are able to see
    You have to add WCS external IP address into ACL (Twilio white list).
  3. Sam Udotong

    Sam Udotong New Member

    Thanks Max. I added the IP address into the Twilio white list which made a real difference - Now from the sip-as-rtmp demo page the call is established for around 20 seconds, which is the identical behavior to what happens when I call in from the softphone.

    However I'm still not able to connect via the RTMP Player - I'm getting the StreamNotFound error. Any thoughts?
  4. Max

    Max Administrator Staff Member

    Please share your flashphoner.log file or send this file to logs@flashphoner.com
    Note, this log file is rotated hourly. Make sure it has logs of the latest test.
    Are you trying to play stream name rtmp_stream1? Because WCS server adds rtmp_ prefix by default.
    With latest builds
    1. Try to revert codec settings to defaults.
    codecs=opus,alaw,ulaw,g729,speex16,g722,mpeg4-generic,telephone-event,h264,vp8,flv,mpv
    codecs_exclude_sip=mpeg4-generic,flv,mpv
    codecs_exclude_streaming=flv,telephone-event
    codecs_exclude_sip_rtmp=opus,g729,g722,mpeg4-generic,vp8,mpv
    2. Try to find and set
    Code:
    video_enabled=false
    in flashphoner.properties then restart WCS server
    With previous build
    If it does not help, you can try one of previous build 2101 as recommended here:
    http://forum.flashphoner.com/threads/sip-as-rtmp-broadcasting-problem.10884/#post-12363
    Last edited: May 15, 2017
  5. Sam Udotong

    Sam Udotong New Member

    My settings where already reverted as is the case in point #1. However I switched video_enabled from true to false as per point #2. Also I kept this setting:
    Code:
    generate_av_for_ua = Twilio Media Gateway
    I restarted WCS server and retested in the sip-as-rtmp demo page (I am playing stream1 and letting WCS add the rtmp_ prefix on its own).

    That fixed the issue! Thanks so much.

Share This Page