Demo server license

Discussion in 'Web Call Server 5' started by Julien, Nov 27, 2018.

  1. Julien

    Julien Member

    Hello,

    I have just moved an existing app to a new server and in the process upgraded WCS from 5.0 to 5.1 and now the app is not displaying the video feed from the IP cams anymore. In the process of debugging this i tried the RTSP stream directly in the "Player" demo on my server's dashboard and again the status says "playing" but no video stream is displayed, so i thought there's probably some firewall issue with my new server but before i contacted the hosting i figured i'd try it on your Demo server so i went to https://wcs5-us.flashphoner.com:8888/ but it shows an error message asking for a license, it seems your demo server is in need of a new license so i figured i'd give you a heads up about this problem.

    Regarding upgrading 5.0 to 5.1, was there any specific code changes on the client side or hook configuration that i should be aware of that might be causing my issue?
  2. Max

    Max Administrator Staff Member

    Hello
    Try to set
    Code:
    rtp_force_synchronization=true
    in WCS_HOME/conf/flashphoner.properties
    then restart WCS server
  3. Max

    Max Administrator Staff Member

    Regarding demo server it is fixed now. It was disk space issue.
    Regarding 5.1
    No changes in Web SDK compatibility and hooks.
    There is a change in REST API ports.
    9091 - HTTP was changed to 8081 HTTP
    8888 - HTTPS was changed to 8444 HTTPS
    https://docs.flashphoner.com/display/WCS5EN/API overview
  4. Julien

    Julien Member

    Thank you Max, setting rtp_force_synchronization=true worked, i can see the streams fine now :)

Share This Page