Mixer creation fails in WCS 5.2.479.

Discussion in 'Web Call Server 5' started by sangsoo, Jan 30, 2020.

  1. sangsoo

    sangsoo New Member

    Hello.
    I just updated the WCS server to check for the patch (5.2.474).
    - "WCS-2267 | Added: AV Mixer C optimization"
    I can't create a mixer stream after the latest 5.2.479 update. (previous 5.2.458)

    1. The call to restapi method "/mixer/startup" fails.
    rest-method :
    upload_2020-1-30_15-54-58.png
    response :
    {
    "exception": "com.flashphoner.rest.server.exception.InternalErrorException",
    "path": "/rest-api/mixer/startup",
    "error": "Internal Server Error",
    "message": null,
    "timestamp": 1580366734925,
    "status": 500
    }
    2. The mixer startup exception log remains in the serverlog.
    upload_2020-1-30_15-56-27.png
    I think it's an update side effect.

    Thanks.
    Last edited: Jan 30, 2020
  2. Max

    Max Administrator Staff Member

    Good day.
    "500 Internal server error" message usually means wrong request parameters. For example, the following bash script works in out test environment:
    Code:
    #!/bin/bash
    MIXER=$1
    STREAM=$2
    WCS_ADDRESS=$3
    curl --data "{\"uri\":\"mixer://${MIXER}\",\"localStreamName\":\"${MIXER}\"}" -X POST -H 'Content-type: application/json' -s http://$WCS_ADDRESS:9091/rest-api/mixer/startup
    curl --data "{\"uri\":\"mixer://${MIXER}\",\"localStreamName\":\"${MIXER}\",\"remoteStreamName\":\"$STREAM\"}" -X POST -H 'Content-type: application/json' -s http://$WCS_ADDRESS:9091/rest-api/mixer/add
    
    Code:
    ./mixerTest.sh mixer1 stream1 localhost
    Please collect a full report as described here including REST query used example ansd send to support@flashphoner.com, we will check.
  3. sangsoo

    sangsoo New Member

    Thank you Max.
    mixerTest.sh also has the same result (500).
    It's hard to check now, but it was normal in version 5.2.458 before the update. (Recently used yesterday)
    We just sent a full report to support@flashphoner.com.
    Thank you.

    Attached Files:

  4. Max

    Max Administrator Staff Member

    We checked your log, reproduced the issue and raised internal ticket WCS-2479. We'll let you know when fix it.
  5. Max

    Max Administrator Staff Member

    sangsoo likes this.
  6. sangsoo

    sangsoo New Member

    Dear Max.
    The problem was solved in version 5.2.481. Perfectly!!!
    Thanks.

Share This Page