Observation of very long startup

Discussion in 'Web Call Server 4' started by Thomas, Jan 21, 2015.

  1. Thomas

    Thomas New Member

    Hi,
    I made a test install of the new wcs4 (version 4.0.1082).
    After starting webcallserver daemon the new wcs-manager is starting but it took more than 50 minutes that it started the actual wcs server. Actually there was not much process activity within those 50 mins.
    Additiionally I observed quite a lot of errors during the initialisation of the database.
    Attached is a snapshot of the manager log file.
    Nevertheless, after that first tests seem to be successful.
    BR, Thomas

    Attached Files:

  2. Max

    Max Administrator Staff Member

    Thomas,
    Thanks for the observation.

    First of all try to uninstall any previous WCS4 version if it was installed.
    Then install the new version from scratch.

    50 minutes is too long time. And it looks like an error.
    In our tests the running process takes about 50-60 seconds on VPS server or about 30 seconds on dedicated quad core server.

    Some questions related to your system:

    1. What is your OS version?
    Code:
    uname -a
    2. What is your java version?
    Code:
    java -version
    2. What is your hardware (VPS, Amazon instance, etc) ?

    Regards,
    Max
  3. Max

    Max Administrator Staff Member

    Example

    Code:
    # uname -a
    Linux T16 2.6.18-164.el5xen #1 SMP Thu Sep 3 04:03:03 EDT 2009 x86_64 x86_64 x86
    Code:
    java -version
    java version "1.7.0_40"
    Java(TM) SE Runtime Environment (build 1.7.0_40-b43)
    Java HotSpot(TM) 64-Bit Server VM (build 24.0-b56, mixed mode)
    Code:
    # cat /proc/cpuinfo
    processor       : 0
    vendor_id       : GenuineIntel
    cpu family      : 6
    model           : 23
    model name      : Intel(R) Xeon(R) CPU           E5410  @ 2.33GHz
    stepping        : 10
    cpu MHz         : 2327.498
    cache size      : 6144 KB
    physical id     : 0
    siblings        : 1
    core id         : 0
    cpu cores       : 1
    fpu             : yes
    fpu_exception   : yes
    cpuid level     : 10
    wp              : yes
    flags           : fpu tsc msr pae cx8 apic cmov pat clflush mmx fxsr sse sse2 ss                                                                                                                                                              syscall nx lm constant_tsc pni vmx cx16 lahf_lm
    bogomips        : 5827.88
    clflush size    : 64
    cache_alignment : 64
    address sizes   : 38 bits physical, 48 bits virtual
    power management:
    
    1024M memory.
    This configuration starts within 50 seconds on VPS server.

    Regards,
    Max
  4. Thomas

    Thomas New Member

    uname -a:
    Code:
    Linux rtcgw02 3.16-0.bpo.3-amd64 #1 SMP Debian 3.16.5-1~bpo70+1 (2014-11-02) x86_64 GNU/Linux
    (Debian Wheezy 7.8)

    Java:
    Code:
    java version "1.8.0_25"
    Java(TM) SE Runtime Environment (build 1.8.0_25-b17)
    Java HotSpot(TM) 64-Bit Server VM (build 25.25-b02, mixed mode)

    Code:
    processor    : 0
    vendor_id    : AuthenticAMD
    cpu family    : 21
    model        : 1
    model name    : AMD Opteron 62xx (Gen 4 Class Opteron)
    stepping    : 2
    microcode    : 0x1000065
    cpu MHz        : 2800.000
    cache size    : 512 KB
    physical id    : 0
    siblings    : 1
    core id        : 0
    cpu cores    : 1
    apicid        : 0
    initial apicid    : 0
    fpu        : yes
    fpu_exception    : yes
    cpuid level    : 13
    wp        : yes
    flags        : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 syscall nx mmxext fxsr_opt pdpe1gb lm rep_good nopl extd_apicid pni pclmulqdq ssse3 cx16 sse4_1 sse4_2 popcnt aes xsave avx hypervisor lahf_lm cmp_legacy svm abm sse4a misalignsse 3dnowprefetch osvw xop fma4 arat npt nrip_save bmi1
    bogomips    : 5600.00
    TLB size    : 1024 4K pages
    clflush size    : 64
    cache_alignment    : 64
    address sizes    : 40 bits physical, 48 bits virtual
    power management:
    

    Code:
    # cat /proc/meminfo
    MemTotal:        2051360 kB
    MemFree:         1115980 kB
    
    Hardware: Virtual machine based on KVM (IAAS cloud provider)
  5. Thomas

    Thomas New Member

    Actually, I had already once uninstalled and reinstalled - very similar result.
  6. Max

    Max Administrator Staff Member

    We tested it with own hardware servers Core i7, Xeon E5410. We also tested it with didgitalocean cloud servers, i.e. Xeon E5-2630L. And it worked well. Only difference I see is the CPU. In our tests we used Intel CPU. Your testing platform is based on AMD Opteron. Try to install WCS to another server: hardware server, Amazon EC2 or digitalocean cloud server.

    Another option, please provide access to your testing server and we will try to check it.
    Send email to logs@flashphoner.com with access details.

    WCS4 requires a lot of CPU resources on startup because it is deploying internal services while starting (REST, Database, Web container, Internal component scans, etc). Maybe your server-instance is too slow in CPU terms.

    Regards,
    Max
  7. Thomas

    Thomas New Member

    Hi Max,
    I installed it meanwhile on Amazon EC2 successfully. Seems that you are right with the assumption concerning AMD Opteron.
    Is there some Java stack incompatibility? I remember from colleague that a test WCS3 worked on a similarv platform (same IAAS provider) quite smoothly.
    BR, Thomas
  8. Max

    Max Administrator Staff Member

    Thomas,
    WCS3 is a lightweight box comparing with WCS4.
    WCS4 has a set of integration and management add-ons such as embedded web-server for REST API, interactive command line interface (CLI) working over SSH, built-in database for applications etc. Some of these add-ons can use particular CPU instructions or hardware accelerations (for example for encryption, SSH, AES). It seems AMD platform does not support such capabilities. Currently we do not have a lot of request regarding AMD, so we suggest to use Intel platform. However if AMD deployment is critical requirement, please contact our support or sales team. We will try to find a solution.

Share This Page