Stopped by session disconnect

Discussion in 'General Discussion' started by Mohit, Jan 9, 2019.

  1. Mohit

    Mohit New Member

    We are getting "Stopped by session disconnect" error, Can somebody will help to resolve this error?
  2. Max

    Max Administrator Staff Member

  3. Mohit

    Mohit New Member

  4. Max

    Max Administrator Staff Member

    We checked your logs. Seems like your RTMP streamer device correctly stops publishing with RTMP command deleteStream:
    The player which plays the stream at the moment closes its connection with message "Stopped by session disconnect". After that, players which try to play the stream get message "Session does not exist".
    So you have to check RTMP streamer device settings to prevent stream unpublishing, or to setup stream republishing.
    If you wish to use stream monitoring functions you should enable it with setting
    Code:
    disable_manager_rmi=false
  5. Mohit

    Mohit New Member

    Thanks Max,

    Before few days we have moved WCS to new high configuration server, and in previous server everything working fine with WCS version 5.1.3603
    FYI, we are using vidiu pro to stream video, and we have observed that vidiu have 'Live' status while we get "Stopped by session disconnect" message
  6. Max

    Max Administrator Staff Member

    Please do the following:
    1. Start to collect traffic dump with tcpdump
    2. Start WCS
    3. Stop traffic dump collection when you get "Stopped by session disconnection"
    Then send us this dump.
    Also, try to:
    1. Publish RTMP stream to Wowza, e.g. rtmp://wza4-demo.flashphoner.com:1935/live
    2. Play the stream from Wowza with some player (e.g. VLC)
    3. Check if stream stops publishsing
  7. Mohit

    Mohit New Member

    OKay will do that,

    You can see in our web portal https://funbetexchange.com:8888 inside monitoring->streaming->real-time->details that some users are connected and for some users status is pending which are recently connected. means streaming is working fine for already connected users but after sometime if user refresh browser or new user try to connect then status will be pending.

    https://1drv.ms/u/s!AtaOL5PZ_MKtiG9pjE9HjDpm5Dij
  8. Max

    Max Administrator Staff Member

    Every stream gets PENDING status right after publish or play request. In case of playback, status changes from PENDING to PLAYING if playback successfully starts, or to FAILED if not.
    In your logs we see playStream requests in PENDING status for streams that is already unpublished, then they changes to FAILED, and this is normal behaviour.
    You can check if stream is published on server with REST API query
    Code:
    http://host:8081/rest-api/stream/find
    {
     "name": "HDMI2525",
     "status": "PUBLISHING"
    }
    
    If stream is published, you will see it in response, if not, response will be 404 Not found.
    So if your RTMP streams are pushed correctly to Wowza and played from it, we need traffic dump to check why WCS supposes stream to be unpublished. If problem occurs with Wowza too, you should check Vidiu Pro setup.
  9. Mohit

    Mohit New Member

    okay, but when stream status is pending for some users that time how those users are able to see stream video which are connected just after stream published
  10. Mohit

    Mohit New Member

  11. Max

    Max Administrator Staff Member

    Please do the following:
    1. Stop WCS
    2. Start to collect traffic dump with tcpdump
    3. Start WCS
    4. Stop traffic dump collection when you get "Stopped by session disconnection"
    Then send us link to collected traffic dump.

Share This Page