Webrtc - SIP calls fails with the las tversion WCS

Discussion in 'Web Call Server 5' started by mbedial, Jan 20, 2020.

  1. mbedial

    mbedial Member

    Hi friends,
    we have an old version of WCS (5.0.2570) that is causing a lot of problems with webrtc/sip voice traffic (mainly from android app to external SIP servers).
    It stops working and we have to restart the WCS almost everyday, and some days even more times.
    We are testing now in other server the lastest version of WCS (5.2.458) but when we make a call from the DEMO web to a mobile, the handset rings and you can answer the call,but ince you answer it, ther is no audio and the call is hangup.

    I've copied exactly the same config that we have in the old version in other server where it works fine. Including codecs, firewall, etc.

    I attach the log of the server.
    BR and thanks in advance.

    Attached Files:

  2. Max

    Max Administrator Staff Member

    Hello,

    The call in the log "Failed by ICE error". Please check firewall and routing settings and verify that the UDP ports are reachable. In case of further investigation, please send additional information (with server config and ifconfig result) per this instruction.
  3. mbedial

    mbedial Member

    Thanks a lot for your quick answer.
    We deactivate the ufw before any testing, so I guess that isn't a firewall problem.
    I've sent an email with the requested logs and a pcap log of all the interfaces.
    To clarify the scenario, we log the Sip user in a local asterisk server port 5080.
    Thanks again.
  4. Max

    Max Administrator Staff Member

    Good day.
    We have checked logs, but the reason for ICE failure by timeout still is not clean. Please provide us SSH access to the server and SIP account details for test call, we will check inplace.
    If acces cannot be provided, please do the following:
    1. Check if SIP call to local Asterisk server woks using third party softphone (Bria for example). If not, check Asterisk settings and make sure firewall is fully disabled.
    2. If third party softphone works, please collect a report as described here including client debug logs and send us.
  5. mbedial

    mbedial Member

    Thanks a lot.
    I've sent you an email with the host and user/pass to access to the server.
  6. Max

    Max Administrator Staff Member

    Checked ufw status on the server
    Code:
    sudo ufw status verbose
    It is active.
  7. mbedial

    mbedial Member

    Hi Max,
    we enabled it after the testing, but when we made the test , it was disable.
    In fact, I've just tested with this configuration:

    root@AST4:/home/imagine800# sudo ufw status verbose
    Status: inactive

    and the problem still exists.

    M
  8. Max

    Max Administrator Staff Member

    Please also let know caller SIP account details and callee which can be used for a test call.
  9. mbedial

    mbedial Member

    Ok, I've sent via email that info.
  10. Max

    Max Administrator Staff Member

    Good day.
    Your server has 2 network interfaces: external and LAN. In flashphoner properties, you've set
    Code:
    ip=external
    ip_local=LAN
    
    but this should be done only if server is behind NAT (it is not).
    So please set
    Code:
    ip=external
    ip_local=external
    
    if WCS should be available from outside via Websocket, or
    Code:
    ip=LAN
    ip_local=LAN
    
    if WCS should be available from LAN only
    In both cases, SIP calls are correctly established with Asterisk PBX on LAN interface
    mbedial likes this.
  11. mbedial

    mbedial Member

    Thanks a lot.
    We've tried it and it works!
    What we don't understand is why in other server where we have the purchased license , it works with this config:

    ip=external
    ip_local=LAN

    I guess that it works because it has an older version with a different SIP stack. Otherwise I can't understand.


    Thanks again.
  12. Max

    Max Administrator Staff Member

    There were many WebRTC fixes since old version in—Āluding ICE. So, it was a bug, and it was fixed too.
    mbedial likes this.

Share This Page