Works on demo but not on my web server page

Discussion in 'Web Call Server 5' started by Corrado Steri, Sep 5, 2019.

  1. Corrado Steri

    Corrado Steri New Member

    I tested my flashphoner server on the demo page and it works correctly, image from the rtsp camera are working nicely.

    Once i copy and paste the code generated in the demo page to my aspx page and try to access it from a browser I get a grey broken screen.

    Same configuration was working 3 months ago. Today i updated WCS to latest version and added new license. Certificates on the WCS server are configured and working in https.

    Any ideas?
  2. Max

    Max Administrator Staff Member

    Good day.
    Please collect a report as decribed here (you can collect logs using script), including browser version and browser console messages, and send to support@flashphoner.com, we will check.
  3. Corrado Steri

    Corrado Steri New Member

    Ok, i found the problem. If i disable the firewall it works.
    This are the ports open as described in the setup manual:

    From command line:

    sudo firewall-cmd --zone=public --list-ports
    30000-33000/udp 8444/tcp 8443/tcp 30000-33000/tcp 1935/tcp
    Last edited: Sep 6, 2019
  4. Max

    Max Administrator Staff Member

    You should also open TCP ports 8081 and 8444 for web examples (and Embed Player) to work. The full firewalld setup to open looks like this:
    Code:
    firewall-cmd --permanent --zone=public --add-port=8888/tcp
    firewall-cmd --permanent --zone=public --add-port=8443/tcp
    firewall-cmd --permanent --zone=public --add-port=1935/tcp
    firewall-cmd --permanent --zone=public --add-port=1935/udp
    firewall-cmd --permanent --zone=public --add-port=554/tcp
    firewall-cmd --permanent --zone=public --add-port=8080/tcp
    firewall-cmd --permanent --zone=public --add-port=8081/tcp
    firewall-cmd --permanent --zone=public --add-port=8084/tcp
    firewall-cmd --permanent --zone=public --add-port=8082/tcp
    firewall-cmd --permanent --zone=public --add-port=8445/tcp
    firewall-cmd --permanent --zone=public --add-port=8444/tcp
    firewall-cmd --permanent --zone=public --add-port=34001-35000/tcp
    firewall-cmd --permanent --zone=public --add-port=30000-33000/udp
    firewall-cmd --permanent --zone=public --add-port=30000-33000/tcp
    firewall-cmd --reload
    
  5. Corrado Steri

    Corrado Steri New Member

    Great!!! with all these ports opened it works great!!!
    Thank you.
    Wouldn't it be better to put this on the setup guide? Thanks

Share This Page