4K streaming, stop in 5 seconds

Discussion in 'Web Call Server 5' started by Nobuyasu Tanaka, Oct 3, 2019.

  1. Nobuyasu Tanaka

    Nobuyasu Tanaka New Member

    Xsplit uses RTMP to push 4K video to WCS. WCS is linked to a web server and implements a custom player. The playback test is done on one PC and two Android devices, but one or two stops in about 5 seconds. How can I make this playback play for a long time?

    Connection diagram:
    https://www.dropbox.com/s/61zws6laxpquodn/RTMP-WCS-WSS.pdf?dl=0
  2. Max

    Max Administrator Staff Member

    Good day.
    Please tell us which version of WCS are you using?
    We are trying to reproduce your case and let you know about the results.
    Last edited: Oct 7, 2019
  3. Nobuyasu Tanaka

    Nobuyasu Tanaka New Member

    Dear Support.
    The version you are using.
    FlashphonerWebCallServer-5.2.302
  4. Max

    Max Administrator Staff Member

    Good day.
    We tested your case with WCS 5.2.302. Works for us.
    Please try switch KeepAlive off for RTMP on the server using the following parameter in flashphoner.properties file:
    Code:
    keep_alive.enabled = websocket, rtmfp
    And then restart WCS:
    Code:
    {WCS home}/bin/webcallserver restart
    If it doesn’t help, please collect a report as described here (you can collect logs using script), including browser version and browser console messages, and send to support@flashphoner.com, we will check.
  5. Nobuyasu Tanaka

    Nobuyasu Tanaka New Member

    Dear Support
    Tested with keep_alive.enabled = websocket, rtmfp set. The situation does not change much. Upload the log.
  6. Max

    Max Administrator Staff Member

    Good day.
    Unfortunately, we did not receive your logs by email.
    If it's possible please provide us SSH access to your server to support@flashphoner.com. We will check.
  7. Nobuyasu Tanaka

    Nobuyasu Tanaka New Member

    We sent log when we tested.
    When it stops in about 5 seconds.
  8. Max

    Max Administrator Staff Member

    Good day.
    If you are testing another source (not 4k) problem persist?

    We also see in log, possible mismatch IP address.
    Check in your flashphoner.properties file as looks ip_local:
    Code:
    ip_local=x.x.x.x
    compare in according your ifconfig.

    Besides that, please for test try using TCP. Is enabled with the following parameter in flashphoner.properties file:
    Code:
    ice_tcp_transport_force=true
    and restart WCS.

    If this does not help, also please send your flashphoner.properties settings file to support@flashphoner.com.
    Last edited: Oct 9, 2019

Share This Page