DigiEye's streams cant be played

Max

Administrator
Staff member
We're testing the fix. Perhaps it will be released next week. Please be patient.
 

fercospos

New Member
Hello Max! May we have a time estimate for the new version? I have a lot of patience, but the client does not stop urging and I need to give them any updates. Thanks!
 

Max

Administrator
Staff member
We're on the final testing stage before release. The fix will be released this week.
 

Max

Administrator
Staff member
We fixed the issue in build 5.2.1988. Please update and set the following parameter:
Code:
jitter_buffer_strictness=TOLERANT
The stream should play.
Please also check if the green flickering occurs with this build and setting.
 

fercospos

New Member
Thanks for the notification Max.

We can't update online because the server is on an isolated network, may we get a way to install offline?

Thanks and best regards,
 

Max

Administrator
Staff member
We can't update online because the server is on an isolated network, may we get a way to install offline?
Please do the following:
1. Download the WCS installastion archive here: 5.2.1988
2. Place the archive to the server
3. Unpack the archive
Code:
tar -xvzf FlashphonerWebCallServer-5.2.1988.tar.gz
4. Stop WCS
Code:
sudo systemctl stop webcallserver
5. Launch the installation script
Code:
cd FlashphonerWebCallServer-5.2.1988
sudo ./install.sh
The script will update the current installation on the server
6. Start WCS
Code:
sudo systemctl start webcallserver
 

fercospos

New Member
Hello Max!

We were able to update the server, but still we can't see the video stream. Checking today's logs I see this info entries:


18:42:29,872 INFO RetryExec - API-ASYNC-pool-7-thread-42 I/O exception (org.apache.http.NoHttpResponseException) caught when processing request to {}->http://localhost:8081: The target server failed to respond
18:42:29,872 INFO RetryExec - API-ASYNC-pool-7-thread-42 Retrying request to {}->http://localhost:8081

From our installation notes, we have the port 8081 available as public zone on the firewall, and I see it's in use by "tproxy":

[root@MEDIASERVER server_logs]# cat /etc/services | grep "8081"
tproxy 8081/tcp sunproxyadmin # Transparent Proxy
tproxy 8081/udp sunproxyadmin # Transparent Proxy

What may I be missing?
 

Max

Administrator
Staff member
The port 8081/tcp should be listened by WCS process itself:
Code:
sudo netstat -nlp | grep java | grep 8081
If not, please check the WCS configuration in flashphoner.properties file: did you changed the parameter http.port? If yes, revert in back to
Code:
http.port=8081
and restart WCS.
If port is listened, but no streams can be played at all, please check if you activated a license on the server.
 
Top