High Latency


New Member
I installed Flasphoner on an Ubuntu server and tried some streams. Sadly we have a latency of 4-5 seconds. The server, the camera and the client are in the same network. If I call the camera via VLC from the client, the latency is around 1 second.

Do you have any idea, where the problem could be?

Some background information:
Flashphoner is the only software running on the server (DELL PowerEdge R240 6G4X9 Xeon E-2224, 4x 3,40 GHz, 8GB Ram).
On the server is a freshly installed Ubuntu server
Only MSE,WSPlayer are working. If I use WebRTS Player I get the error “none of preferred mediaproviders available”.
I tried it on windows 10 with Firefox and Chrome.


I created an empty html file with only the code for the embedded player with WebRTC. If i start this file on my local PC everything works great and the delay is much lower. If I upload the exactly same file on my server, I get the error "none of preferred mediaproviders available".
If I call the stream from the Flasphoner Admin "Embed player" with WebRTC only it works also. Kind of strange :(
Last edited:


Staff member

Could you provide few screenshots?
Generally WebRTC is not working if you connect over http not https.
Try to use https everywhere. Check also browser console press F12.


New Member
This was a typical case of "the error is in front of the screen"
With https everything works great and with WebRTC the delay is very low.