Origin edge server setup

Max

Administrator
Staff member
The password is kept in the yml file:

/usr/local/FlashphonerWebCallServer/conf/database.yml

Example:

admin: {username: admin, password: 21232f297a57a5a743894a0e4a801fc3, active: true}

Here 21232f297a57a5a743894a0e4a801fc3 = md5("admin")

Therefore you can set any password and restart WCS server to apply changes.

Example:

MD5("12345") = 1f32aa4c9a1d2ea010adcf2348166a04

Therefore:

admin: {username: admin, password: 1f32aa4c9a1d2ea010adcf2348166a04, active: true}

Login: admin
Password: 12345

If you still can't connect as admin@localhost -p 2001, make sure port 2001 is not bound by another application on your server.

netstat -nlp | grep 2001
 
Hi,

The origin server is behind load balancer and the edge server is not behind load balancer. https://edge1.com:8444/rest-api/cdn/show_routes response

{
"exception": "com.flashphoner.rest.server.exception.NotFoundException",
"reason": "com.flashphoner.rest.server.exception.NotFoundException, Not Found, No routes, ts: 1660291446628, path: /rest-api/cdn/show_routes",
"path": "/rest-api/cdn/show_routes",
"error": "Not Found",
"message": "No routes",
"timestamp": 1660291446628,
"status" : "404"
}

All the ports required for flashphoner is opened. On the edge server we cannot see the stream on the two-way streaming page
 

Max

Administrator
Staff member
Please check if origin server and edge server can see each other by CDN signaling connections. Send REST API query /cdn/show_nodes both to origin and edge. If edge server cannot connect to origin server (there is no origin in edges connection list and vice versa), please check if CDN signaling port 8084/tcp is available in both directions on origin and on edge.
 

Max

Administrator
Staff member
cdn_enabled=true
cdn_ip=172.xx.xxxx.xx
cdn_nodes_resolve_ip=false
cdn_role=origin

Following properties added to edge server

cdn_enabled=true
cdn_ip=172.xx.xxxx.xx
cdn_nodes_resolve_ip=false
cdn_point_of_entry=172.xx.xxxx.xx
cdn_role=edge

Try to disable DNS resolving and use IP addresses everywhere:
cdn_nodes_resolve_ip=false
 

Max

Administrator
Staff member
Hello

But we cannot play rtmp stream using the edge server in video js player
Are you sure that video.js can play RTMP streams?
Adobe Flash Player is not currently supported in most of browser versions.
As we know video.js uses swf (Adobe Flash) binary for RTMP playback.
Make sure your browser supports Flash (maybe you are using quite old browser version with working Flash plugin).
Try to play the same RTMP stream in VLC player. VLC supports RTMP playback.
Make sure you pass aclAuth param for RTMP playback
 

Max

Administrator
Staff member
Please use this extension to enable/disable CORS in Chrome browser: Allow CORS: Allow-Control-Allow-Origin
This page returns empty response:
1661327392203.png

Please check if WCS is running on this address and listens the port 9091. Make sure this is not a load balancer address.
If nofing helps, please provide SSH access to the server using this form.
 

Attachments

Max

Administrator
Staff member
Now it seems like the console example is working:
1661332640919.png

Please do not forget to enable CORS in the extension: toggle this picture if it is grayed
1661332802495.png
 
Top