rtsp.auth fails to connect


New Member
Hello team.

We're running a WebCallServer to embeb some RTSP streams from a couple DVR systems in our management tool. During the tests, from the WCS portal we can reach on the player tool the rtsp steam with the format rtsp://user:pass@dvr_ip:port/h264?device=cam_ip&channel&stream.
This is working properly, but when we add to rtsp.auth the line rtsp://dvr_ip:port/h264?device=cam_ip&channel&stream user pass and after reboot we try to access rtsp://dvr_ip:port/h264?device=cam_ip&channel&stream we get a "FAILED Failed to connect to rtsp stream" message on the player.

The password has the "^" character, so the password on the URL works when we replace it for "%5e". We tried both methods on the rtsp.auth file. Also tried defining on the file only the rtsp://dvr_ip:port user pass (without device IP, channel or stream) but that didn't either work.

What are we missing?

Thanks and best regards,

Last edited:


Staff member

It seems the rtsp.auth works improperly. We will check.
Anyway, If you want to hide RTSP login and password from player, you can map RTSP address to a stream name using REST API.

POST /rest-api/rtsp/startup HTTP/1.1
Content-Length: 56
Content-Type: application/json
    "uri": "rtsp://user:pass@dvr_ip:port/h264?device=cam_ip&channel&stream",
    "localStreamName": "stream1"

Therefore RTSP stream will be played as "stream1" and login and password details will be hidden.


New Member
Hi Max, thanks for the response. We can't use REST as the web server is out of the VPN where the final users will reach the WCS, so they need to get the stream only with the iframe information (and of course hidding the credentials).

We've seen in a couple examples in the forum some entries for rtsp.auth with format rtsp://demo:demo@whatever admin admin, but it's not clear if the demo/demo are the RTSP stream credentials, or those are admin/admin and demo/demo is for the FlashphonerWCS web portal user logging in.



Staff member
We have tested RTSP credentials file feature in build 5.2.1759. It works. Please update and add the desired RTSP URL to /usr/local/FlashphonerWebCallServer/conf/rtsp.auth file in the following form:
rtsp://dvr_ip:port/h264?device=cam_ip&channel&stream user pass
It should work. If not, collect a report as described here:
1. Restart WCS.
2. Try to play the RTSP stream
3. Collect a report using script: Getting logs with report.sh script
cd /usr/local/FlashphonerWebCallServer/tools
sudo ./report.sh --sysinfo --conf --tar
Then send the report archive using this form.