change wss default port

Max

Administrator
Staff member
If piblic IP and local IP are bound to a different network interfaces, you should
1. Set WCS IP options as follows
Code:
ip=your_public_ip
ip_local=your_public_ip
2. In /etc/hosts file, set SIP server domain name
Code:
sip_server_ip sip-server
3. When making a call, use SIP server domain name in SIP credentials:
1683543539216.png
 

manh.chu

New Member
I tried this way, but WCS server using IP public connect to IP local of SIP server. It can't register to server althought I turn off firewalld.

1683596573471.png
 

manh.chu

New Member
Before I tried setting options ip and ip_local by IP local and using http.address= IP public. I can register to SIP server and make calls but in the browser client can't send or receive rpt packet and after 6-7s this call auto
 

Max

Administrator
Staff member
WCS has no network packets routing functions. You need to place both WCS and SIP server to your private network and set up a router with NAT to forward websocket and media ports connections from web clients to WCS:
1683599547220.png
 

manh.chu

New Member
I intend to follow my diagram because when setting connect both client and SIP server by IP local, I test make SIP video call does not have freeze frame. I tried to connect to wss of SIP server Asterisk to make SIP video call, it work betters.
The opposite setup connects both client and SIP server by IP public it has often freeze frame.
I tried to change to TCP transport, setting webrtc_cc_max_bitrate, constraints.video.maxBitrate is lower than the default it still suffers.

Below is bandwidth testing with the client:
1683621932464.png


Bandwitdth with SIP server:
1683621976297.png
 

Max

Administrator
Staff member
The opposite setup connects both client and SIP server by IP public it has often freeze frame.
Please check is there any freezes when publishing and playing a stream using Media Devices example (with various resolutions/bitrates). If no freezes in this case, the bottleneck is probably between WCS and SIP server because media traffic goes via SIP server. So you should test a channel between WCS and SIP server.
 
Top