AWS Marketplace AMI for CDN and autoscaling

Hi,
Based on this link https://forum.flashphoner.com/threads/flashphoner-license-not-renewed.13038/, we faced a same issue yesterday where our license changed to expired state even though auto-renew is enabled last month itself. This broke our production system streaming functionality.

So we are planning to use AWS marketplace AMI https://aws.amazon.com/marketplace/pp/B07ZVRPH5G to avoid such license expiry issues.

I need to know whether this marketplace AMI can be used for WCS CDN and autoscaling respectively.
Note: I have also added some custom configuration in flashphoner properties file.

Expecting a quick response.
 

Max

Administrator
Staff member
Good day.
I need to know whether this marketplace AMI can be used for WCS CDN and autoscaling respectively.
Yes, the marketplace WCS AMI can be used to deploy CDN. For autoscaling, you should buy and activate license on this step, or try to use AWS CloudFormation. We now working on documenting CDN setup with load balancing in ticket WCS-2797.
 

Max

Administrator
Staff member
You mean marketplace flashphoner AMI can't be used for autoscaling configuration. is that right?
It cannot be used in autoscaling configuration as described in docs because Amazon billing can be incorrect for custom AMI.
Using Cloud Formation can be solution (in this case Amazon declares their billing to be correct), but we working on it yet.
 
It cannot be used in autoscaling configuration as described in docs because Amazon billing can be incorrect for custom AMI.
You mean Marketplace AMI. right?
But if we create a custom AMI by installing flashphoner manually and activating the license, autoscaling will work. Am I right?
 

Max

Administrator
Staff member
You mean Marketplace AMI. right?
If you create an instance from marketplace AMI, then create a custom AMI from this instance, and then use this custom AMI as autoscale group base, Amazon can bill this incorrect.
But if we create a custom AMI by installing flashphoner manually and activating the license, autoscaling will work. Am I right?
Yes.
 
Okay. Thanks Max. We planned to use AWS marketplace AMI as we don't to face the license auto-renew issue like we faced yesterday since more customers are using the service right now.
If the license expiration issue will not happen again, I think our current setup is good enough.

One question:
What if we use AWS marketplace AMI for autoscling and billing comes incorrect? Is the servers using autoscaling AMI will become useless?
Just to know what happens on that case.
 

Max

Administrator
Staff member
Is the servers using autoscaling AMI will become useless?
Yes, the servers using custom AMI may become useless unless the separate license is activated while creating this AMI.
 
Last edited:

Max

Administrator
Staff member
Good day.
We tested and added the step by step instruction to deploy load balancer with autoscaling based on AWS Marketplace AMI. Please read details here.
 
Great Max. Thanks for the update.

It cannot be used in autoscaling configuration as described in docs because Amazon billing can be incorrect for custom AMI.
But you said in above thread that Marketplace AMI can't be used with autoscaling since there is some billing issues with that AMI.

Is that fixed now?
 

Max

Administrator
Staff member
But you said in above thread that Marketplace AMI can't be used with autoscaling since there is some billing issues with that AMI.
We found a workaround. For Amazon billng to work correctly, Marketplace AMI should be used to create an instance, but not custom one. So User data script should be used to customize server settings on first instance start. We checked if it works and described in docs.
 

Max

Administrator
Staff member
With AWS Market place AMI, is that possible to change, delete and add REST API users and its password during launching instance. I mean in launch template userdata.
Yes, it is possible. The user settings are stored in /usr/local/FlashphonerWebCallServer/conf/database.yml file (see the doc here). So you can add users and change their passwords in users section (this is the example out of the box):
Code:
users:
  admin: {username: admin, password: 21232f297a57a5a743894a0e4a801fc3, active: true}
  demo: {username: demo, password: fe01ce2a7fbac8fafaed7c982a04e229, active: true}
  restAdmin: {username: restAdmin, password: 04f91d0737f35adea9a875920e0f2cba, active: true}
...
Note that you shoukd generate md5 hash for users new password to place there. By default admin password in AWS instance is the instance id.
 
Max, the marketplace AMI used Amazon Linux AMI 1 which is going to reach end of support. Also many packages are not available to install like coturn (which is available in Amazon linux 2 but not in Amazon Linux 1)

https://aws.amazon.com/amazon-linux-ami/

Can you please update the Flashphoner AMI to Linux 2 with latest WCS?
 
Last edited:
Top