Can not start transponder Error

Max

Administrator
Staff member
Did you publish a stream before starting transponder?

This is how we test

1. Publish a stream "1e86" using Two Way Streaming

2. Start a new transponder using REST request
Code:
https://demo.flashphoner.com:8444/rest-api/push/startup
{
  "streamName": "1e86",
  "rtmpUrl": "rtmp://localhost:1935/live"
}
3. RTMP stream is being republished as rtmp://localhost:1935/live/rtmp_1e86

You can play this stream.

Please note. WCS server adds the prefix "rtmp_".
So you can't republish stream to youtube via our demo server because stream key will be rtmp_{streamKey}.

To get this working with youtube, you would need your own server with server-side configuration

Code:
rtmp_transponder_full_url = true
to use exactly passed url i. e. "rtmpUrl": "rtmp://localhost:1935/live/mykey"

or set this setting to empty value
Code:
rtmp_transponder_stream_name_prefix =
to remove rtmp_ prefix

You can read about these options in the docs.

rtmp-transponder-from-webrtc.png
 

yogesh.kumawat

New Member
Hello Sir,

when we call custom url for the api (https://192.***.1.**:portno/rest-api/push/startup). it returing "Error: connect ECONNREFUSED 192.***.1.**:portno".

and on the other side when I tried to publish the youtube URL it giving error "net" ERR_CERT_AUTHORITY_INVALID" while I have already https integrate Ip address." and I have already configured required configuration for the custom server. such as

rtmp_transponder_full_url = true
rtmp_transponder_stream_name_prefix =


can you provide us a possible solution so we can implement it asap.

Thanks.
 

Max

Administrator
Staff member
If you provide SSH access to your server, we will be able to finalize and validate installation.
1) SSH access to the server.
2) SSL certificates for your custom domain, i.e. tortmp.mycompany.com (we need valid domain name and IP address).
Streaming won't work without SSL certificates. It should be imported according docs.

You can send all details via this Report form.
 

yogesh.kumawat

New Member
Hi Max,

when i have call api "/rest-api/stream/find" is returing result:

{
"exception": "com.flashphoner.rest.server.exception.NotFoundException",
"path": "/rest-api/stream/find",
"error": "Not Found",
"message": "NOT FOUND",
"timestamp": 1592314080375,
"status": 404
}

that means our server configuration looking fine. but when I have called API "/rest-api/push/startup", it returning error.

Error:
{
"exception": "com.flashphoner.rest.server.exception.NotFoundException",
"path": "/rest-api/push/startup",
"error": "Not Found",
"message": "Can not start transponder",
"timestamp": 1592207804134,
"status": 404
}

I have already informed you about it and already configured the required setting.

I wrote in the last thread that SSL issue but if issue having due to SSL then it will be in all API's. but here "/rest-api/stream/find" API working.

This server is on my trial period. So can you confirm that the trial server supports all the configuration that is completely available in the licensed account or limited?

During this testing, I want to sure that streaming functionality is working fine in all the API's.

so please can you confirm for me all about details for the trial account and API's and also confirm what we can do for a developer account to check the complete configuration.
 

Max

Administrator
Staff member
Hello

There are two limitations for Trial License:
1. 30 days period.
2. Watermarks on the streams.

No other feature limitations.
I am facing error in the api
This is not an error. This is correct behavior.
404 status means "Stream Not Found" or no publishing stream found.

1. Publish a stream.
You will see status PUBLISHING and /rest-api/stream/find_all should return publishing stream.
See attached screenshot https://forum.flashphoner.com/threads/can-not-start-transponder-error.12968/post-23310

2. Re-publish stream using /push/startup
This will return 404 if published stream not found and 200 OK if stream found and republished successfully.
 

yogesh.kumawat

New Member
Hi Max,

I have already followed all steps and configuration for the publish stream but I am getting error something like :

Error:
{
"exception": "com.flashphoner.rest.server.exception.NotFoundException",
"path": "/rest-api/push/startup",
"error": "Not Found",
"message": "Can not start transponder",
"timestamp": 1592207804134,
"status": 404
}

I have already posted this error two times in this thread but still couldn't get a possible solution. can you please provide me the solution for the above error, I have already followed step for the publish stream on the custom server.
 

Max

Administrator
Staff member
Connection times out on attempt to establish SSH connection with the credentials.
Please verify that connections to the port are allowed.
 

yogesh.kumawat

New Member
Hello Sir,
I have changed some configuration on the server and reshared details to you on the above-given link. can you please check these details and provide me a possible solution.
 

Max

Administrator
Staff member
We still cannot connect using credentials you've provided
Code:
ssh: connect to host ***.**.**.*** port ****: Connection timed out
Please verify that connections to the port are allowed and server is up 24/7
 

Max

Administrator
Staff member
Good day.
We checked your server.
Please update JDK 11 to JDK 12 or 14 (steps 1-4 from this page).
Unfortunately, we cannot publish anything to your server because ports 8443 (wss) and 1935 (rtmp) seems to be rejected on router. Please allow streams publishing to the server or publish some stream 24/7 to test RTMP re-publishing.
Also, please add the following settings to flashphoner.properties if you plan to republish stream to Youtube
Code:
rtmp_transponder_full_url = true
rtmp_transponder_stream_name_prefix =
 

yogesh.kumawat

New Member
Hello Sir,

We have set up all required configuration. Please check it again and confirmed me everything is looking fine or need to configure more settings.
 

Max

Administrator
Staff member
We just tried to reproduce the issue:
1. Published RTMP stream (because WebRTC publishing does not work due to closed media ports) to your server
1592910829675.png
2. Re-published stream as RTMP to our demo server
1592910979927.png
3. Played re-published stream on demo server
1592911037592.png
So your server seems to be working.
Please chaek again. Note that media ports (31001-32000/udp) should also be opened and forwarded on your router for WEbRTC publishing to work.
 

yogesh.kumawat

New Member
Hello Sir,

I have allowed media port "31001" but still, API Showing the same error and stream publishing failed. can you please check or provide me details for the same
 

Max

Administrator
Staff member
API Showing the same error and stream publishing failed
Please check if target server for RTMP stream republishing is available, RTMP port ia not blocked on this server, and sofware to capture the stream (WCS, Wowza, Nimble etc) is already running
 

yogesh.kumawat

New Member
Hello Sir,

how we can check the target server is ready to publish stream?
we have already enabled most of the ports, is there any specific port to the RMTP.
Can we need to install the software (WCS, Wowza, Nimble ) or already installed?
 
Top